FFMPEG is a set of tools used to convert, stream and play many media file formats. You can install it under Ubuntu with this command:

sudo apt-get install ffmpeg

Sometimes while using FFMPEG under Ubuntu we may get this error:

 [WARNING] : error running ffmpeg

This error is due to the fact that there are some extra libraries that need to be installed for FFMPEG. This includes some encoders needed by some formats such as MP3, AAC, H.263, H.264, MPEG4, XVID, etc.

To fix this error under Ubuntu 11.10 Oneiric Ocelot, you need to install extra FFMPEG libraries with this command from the terminal:

sudo apt-get install libavcodec-extra-53

For Ubuntu 11.04/10.10/10.04, you can install missing FFMPEG libraries with his command:

sudo apt-get install ffmpeg libavcodec-extra-52

That's it!