0

There are many reasons that might be behind this kind of error:

"Could not get lock /var/lib/apt/lists/lock"

But this error can occur frequently when you try to make an update for the repositories using this command: sudo apt-get update. To fix this error quickly, you can try one of these solutions:

1. Open the terminal and run one of these commands:

sudo rm /var/lib/apt/lists/lock

or

rm -f /var/lib/apt/lists/lock

or

killall -9 apt-get aptitude

Then make an update with this command:

sudo apt-get update

2. Also, If you receive this error:

E: Could not get lock /var/lib/dpkg/lock

Via the terminal, run this command to unlock it:

rm -f /var/lib/dpkg/lock

Then update with this command:

sudo apt-get update

If you have more solutions for this error, then add them in the comment form given below.

Good Luck!

Post a Comment

 
Top